Forum

Please or Register to create posts and topics.

OC5 Semisub Modeling

Hi David,

Is there any way to build OC5 semi-submersible models in Qblade to do the simulation? Is the code available for download or I can just only modify the data manually?

Best Regards,

Easey

Hello Easey,

there is a model of the OC5 setup availiable on Zenodo as part of a deliverable from the FLOATECH project.

BR,

David

Hi David,

I have downloaded the zip, then I input the trb file as Figure 1 shows, what about the other two files? Is that already ok? And I can’t find the codes of substructure detail in the main structure input file.

Then after I just input the trb file, the model could run, but when I modified the RPM to zero, There was an error pop-up as Figure 2 shows, how should I deal with that?

BR,

Easey

Uploaded files:
  • You need to login to have access to uploads.

Hi Easey,

you correctly imported the turbine.

As to the issue you are having to run the model: thats most likely related to your simulation settings (timestep,m rampup, control, etc.). The error you are getting indicates that the structural model is not converging.

I quickly tested the model on QB_CE 2.0.6.4 and its running fine on my side with the default simulation settings, even when RPM is fixed to zero.

BR,

David

Hi David,

Do you mean in your simulation, you just changed the RPM to zero with other settings keeping default, the model runs well, right?

If I need to change the ramp-up, RPM, and initial displacement at the same time to achieve the free decay test, how can I avoid the uncovering of the model? (In the free decay test, I need to set the RPM to zero, and the condition is NO wave NO wind, with air density=0, and I also need to set some initial displacement of surge, pitch, or heave)

BR,

Easey

Hello Easey,

you should not set the air density to zero. This is probably causing your issues. Setting the density to zero can cause unwanted behavior, as this quantity is used in the evaluation of many other parameters.

If you want to explude aerodynamic forces there is a dedicated option under the “Structural Simulation Settings”, simply set “Include Aero Forces & Moments” to “Off”. You could also reach a similar behavior if you set the density to a very small nonzero values such as 1e-5.

Regarding the rampup: You should also use rampup during the decay test. The mooring lines require the rampup time to settle. Furthermore, during rampup the model is held in place (so your initial displacements, rotations wont be affected by the rampup).

BR,

David

Hi David,

When I tried to reproduce the results in the Qblade document of the free decay test, I found some problems in the settings of rumpup.

As you can see in Figure 1, both the range and period of the simulation result (Surge) is in good agreement with the provided Qblade validation document. However, in this simulation, I set the rumpup time as 0.1s.

The result will differ from the document if I use the default rump-up time (20s). I made a comparison as Figure 2 shows (When I noticed the results were different, I stopped the simulation rumpup=20). It seems that rumpup does affect the free decay test.

Does the problem happen in rump-up? Since only when I cancel the rump up time, the free decay result be the same as the document.

BR,

Easey

Uploaded files:
  • You need to login to have access to uploads.

Hello Easey,

the ramp-up time is needed for the following:

a) to ramp-up the rotor rotation at the beginning of the simulation

b) to set the initial collective blade pitch angle and rotor yaw angle

c) to make the mooring lines settle into their relaxed (catenary) shape

Since in the case of decay tests your are not rotating, pitching or yawing the rotor, only point c) is relevant to you.

If the mooring lines dont have enough time to settle (0.1s is far too short for this) they will cause transient loads due to their settling at the beginning of the simulation when data is recorded.

If you look at the visualization you can easily identify this as the issue. While results won’t converge (rather diverge) for a ramp up time tending to zero they will converge for a ramp up time tending to a larger timespan. You could perform a sensitivity study to see what ramp-up time is needed to get convergence, but from experience 20s should be ok for the OC5.

BR,

David

Hi David,

I found that 0.1s is OK for the OC4 model but unavailable for the OC5 model. In the OC4 free decay test, I can get the same result as the Qblade document only when setting the rump-up as 0.1s, u can see the setting table in Figure 1 shows. If I set the ramp-up greater than 0.1s, the results would be different from the Qblade validation document. In addition, I also found that to surge and pitch decay, the ramp-up time should be set as 0.1 to get the same result, but the heave ramp-up should be set as 20s. Is that safe to say my settings for the OC4 free decay test are correct? If not, would you please point out where the error is?

As for the effects of different ramp-up times, I set a series of settings and showed the difference based on the OC5 surge decay test as Figure 2 shows.(the shortest I can do is 3s after trying)

And there’s another problem, I’m trying to reproduce the OC5 free decay test provided on Zenodo.

As Figure 3 shows, when I use the same settings as the OC4 free decay test except for the rump-up time to do the OC5 free decay test, the response of surge would always be smaller than the document, and I didn’t find any other way to achieve the same result as document shows.

I posted my OC5 setting table as Figure 4 shows below, would you please point out where the problem is and tell me how can I reproduce the results in the document?

Thanks a lot!

BR,

Easey

 

 

Uploaded files:
  • You need to login to have access to uploads.

Hi Easey,

I can only reiterate that you should use a sufficiently long “ramp up time”. If the ramp-up is too short the results are not representative at all for a “real life” scenario.

I see that you are using the latest version of the OC5 model from Zenodo, which was recently uploaded by my colleague Robert. This model was tuned to match experimental wave tank tests that included waves (no decay tests). To match the tests a constant force (SUB_HYDROCONSTFORCE) needed to be added to match the experiments (due to a connected cable bundle). See also:

…As previously mentioned, two preloads acting at the platform reference point were introduced to the FAST platform model. The purpose of these preloads was to mimic the influence of the measurement cable bundle that was attached to the platform in the wave tank (and whose properties were not measured).

[F. Wendth – Verification and Validation of the New Dynamic Mooring Modules Available in FAST v8]

For decay tests of this turbine this force needs to be removed, or deactivated. This can be done by simply remove this part (SUB_HYDROCONSTFORCE) from the substructure file, or “overwriting” the keyword, for example: SUBXXX_HYDROCONSTFORCE.

Other than that you settings should be fine. I think with this change you should arrive at the desired result!

BR,

David

Uploaded files:
  • You need to login to have access to uploads.
Easey has reacted to this post.
Easey