Please or Register to create posts and topics.

Set Graph ylim xlim manually wont work

Maybe im just stupid but if I try setting the y an x axis limits manually it just keeps jumping back to the “automatic” limits.

Might be a bug to fix. (Or is it a feature? 😛 )

Found out that you actually have to tick the “no automatic graph scale” by right klick onto the graph window. It’s not ticked by default. However if you change the scales in the “Graph Settings -> Styles and Axes” and untick the “Automatic: limits” and have the “no automatic graph scales” unticked this has the highest priority and will still scale your graph automatically.

Hi Johannes,

this is indeed the intended behavior. The “automatic graph scales” option overrides in this case. I actually rarely use the graph scales settings directly – if I want to change the range within a plot I usually simply deactivate “automatic graph scales” and then zoom the graph to the respective range using the mouse wheel, while pressing x, or y on the keyboard to adjust the scales of the axes individually.